首页 >股票知识 > 公式理论 > 正文

通达信竞价优选选股指标公式

时间:2023-01-18 15:23:01 来源:股票知识

去st:=IF(NAMELIKE('退市') OR NAMELIKE('*ST'),0,1 );

去退市:=IF(NAMELIKE('ST') OR NAMELIKE('退市*'),0,1 );

去KCB:=IF(CODELIKE('68'),0,1);

去CYB:=IF(CODELIKE('30'),0,1);

去BJS:=IF(CODELIKE('80'),0,1);

去次新:=BARSCOUNT(C)>30;

去除停牌:=NOT(DYNAINFO(7))=0;

TJ:=去除停牌 AND 去退市 AND 去ST AND 去KCB AND 去CYB AND 去BJS AND IF(INBLOCK('银行'),0,1) AND IF(INBLOCK('证券'),0,1);

开幅%:=(O-REF(C,1))/REF(C,1)*100;

X_1:=(OPEN/REF(CLOSE,1)-1)*100;

X_2:=DYNAINFO(15)/OPEN/100;

X_3:=X_2/CAPITAL*100;

X_4:=X_2/REF(ma(vol,5),1)*240;

X_5:=X_1<6 AND X_1>3;

X_6:=X_4>10 AND X_4<60;

X_7:=X_4*X_3/OPEN*20;

X_8:=IF(X_7>10 AND X_7<100,X_7,0);

X_9:=IF(X_5 AND X_6 AND X_3>0.3 AND X_8>10 AND X_8<100,X_8,0);

X_10:=IF(CODELIKE(1),0,1);

X_11:=IF(CODELIKE(2),0,1);

X_12:=IF(CODELIKE(3),0,1);

X_13:=IF(NAMELIKE(4),0,1);

X_14:=IF(NAMELIKE(5),0,1);

X_15:=DYNAINFO(17)>0;

优选:X_9>10 AND X_10 AND X_13 AND X_14 AND X_15 AND X_11 AND X_12,COLORFF00FF;

相关专题: